Официальный форум СВД Встраиваемые Системы
15 Июля, 2020, 02:32:30 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
 
 
 Сайт СВД ВС  Начало   Помощь Поиск Войти Регистрация  
Страниц: [1]   Вниз
  Печать  
Автор Тема: AppBuilder и mipsbe  (Прочитано 513 раз)
AndreyT
Интересующийся

Сообщений: 5


« : 17 Января, 2020, 15:53:44 »

Здравствуйте!

QNX 6.5.0.

AppBuilder не поддерживает target на mipsbe?
Или я что-то не так настроил?

Записан
Андрей Докучаев
Сотрудник СВД ВС
Ветеран

Сообщений: 837



WWW
« Ответ #1 : 21 Января, 2020, 11:40:18 »

QNX 6.5.0.

AppBuilder не поддерживает target на mipsbe?

Добрый день!

В 6.5.0 Photon действительно не поддерживает mipsbe, более того, начиная с версии 6.6.0 оконное окружение Photon в QNX отсутствует. Поддержка Photon в том числе и на требуемой платформе в настоящий момент осуществляется только в ЗОСРВ "Нейтрино".
Записан

AndreyT
Интересующийся

Сообщений: 5


« Ответ #2 : 21 Января, 2020, 12:36:04 »

Т.е. программировать на AppBuilder для mipsbe нельзя?
Только на "чистом" Photon'e ?
Записан
Андрей Докучаев
Сотрудник СВД ВС
Ветеран

Сообщений: 837



WWW
« Ответ #3 : 21 Января, 2020, 12:55:43 »

Т.е. программировать на AppBuilder для mipsbe нельзя?
Только на "чистом" Photon'e ?

Пограммировать можно на и в чем угодно, а вот собрать бинарник под эту архитектуру будет невозможно в QNX 6.5.0. Исходный код же приложений Photon в большинстве случаев от архитектуры к архитектуре меняется мало.
Записан

AndreyT
Интересующийся

Сообщений: 5


« Ответ #4 : 21 Января, 2020, 13:01:39 »

К сожалению, попытка компилировать код, сгенерированный AppBuilder'ом для x86 , для mipsbe заканчивается неудачей. Библиотеки для mipsbe, видимо сильно отличаются...
Записан
Андрей Докучаев
Сотрудник СВД ВС
Ветеран

Сообщений: 837



WWW
« Ответ #5 : 21 Января, 2020, 14:04:56 »

К сожалению, попытка компилировать код, сгенерированный AppBuilder'ом для x86 , для mipsbe заканчивается неудачей. Библиотеки для mipsbe, видимо сильно отличаются...

Повторяю еще раз - скомпилировать приложение Photon для mips на QNX 6.5.0 невозможно. В комплекте нет компонентов Photon для Mips, требуемых приложению для сборки. Единственный вариант - использовать ЗОСРВ.
Записан

AndreyT
Интересующийся

Сообщений: 5


« Ответ #6 : 21 Января, 2020, 14:11:58 »

Прошу прощения,  название папки на host-машине привело к недопониманию.  Конечно же "Нейтрино" (КПДА.10964-01)
Записан
Андрей Докучаев
Сотрудник СВД ВС
Ветеран

Сообщений: 837



WWW
« Ответ #7 : 21 Января, 2020, 14:21:02 »

Прошу прощения,  название папки на host-машине привело к недопониманию.  Конечно же "Нейтрино" (КПДА.10964-01)

Хорошо, тогда вопрос какая именно версия ЗОСРВ? Также просьба приложить информацию об ошибке либо в виде файла, либо под спойлером в сообщении.
Записан

Олег Большаков
Администратор
Житель форума

Сообщений: 3127



WWW
« Ответ #8 : 21 Января, 2020, 15:16:19 »

AndreyT, как Вам уже ответили, Photon поддерживается не для всех типов процессорных архитектур. В случае наличия необходимых для сборки модулей Вы можете скорректировать список доступных в PhAB процессорных архитектур в файле $QNX_HOST/usr/photon/appbuilder/nonphoton_targets.def (в нём перечислены недоступные для сборки архитектуры). Вы также можете вручную скопировать или переименовать каталог src/gcc_ntoppcbe в src/gcc_ntomipsbe в корневом каталоге проекта и подправить Makefile.
Записан

AndreyT
Интересующийся

Сообщений: 5


« Ответ #9 : 21 Января, 2020, 16:03:19 »

Спасибо!  Все получилось..
Записан
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP © 2002-2020 СВД Встраиваемые Системы.
При использовании материалов сайта ссылка на forum.kpda.ru обязательна.

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines | © Aiwan. Kolobok smiles | Sitemap
Valid XHTML 1.0! Valid CSS!
Сайт СВД ВС

В последний раз google посещал эту страницу 20 Мая, 2020, 06:38:29